Material Programación I

A l@s alumn@s  de de 1º BD Matutino  recuerden que el próximo viernes 28 tenemos el escrito de Programación I correspondiente a junio. Les dejo algunos de los pseudocódigos  y diagramas de flujo, trabajados en PseInt, para practiquen. Recuerden utilizar la ventana del paso a paso, con detalle explicado, para entender mejor los algoritmos implementados.

Los temas a evaluar corresponden a los conceptos de:

  • Variable
  • Contador
  • Acumulador
  • Diagrama de flujo
  • Pseudocódigo

Estructuras de control:

  • Si…entonces
  • Mientras….hacer

Algunos ejemplos trabajados:

Entrar gratis a un baile si se es dama y mayor de edad.
Proceso entrarAlBaile
Escribir ‘Ingrese edad’
Leer edad
Escribir ‘Ingrese sexo f – Femenino m – Masculino’
Leer sexo
Si edad>=18 Y sexo=f Entonces
Escribir ‘Puede entrar gratis al baile’
Sino
Escribir ‘NO puede entrar gratis al baile’
FinSi
FinProceso
baile

Determinar el mayor de dos números ingresados por teclado.

Proceso determinarElMayor
Escribir “Ingrese un numero”;
Leer numero1;
Escribir “Ingrese otro numero”;
Leer numero2;
Si numero1 > numero2 Entonces
Escribir “El mayor es: ” , numero1;
Sino
Si numero1 < numero2 Entonces
Escribir “El mayor es: ” , numero2;
Sino
Escribir “Los numeros son iguales”;
Fin Si
Fin Si
FinProceso

mayor

Hallar el promedio de una lista de números positivos terminada con -1.

Proceso promedioLista
numero<-0;
acumulador<-0;
contador<- -1;
Mientras numero <> -1 Hacer
acumulador<-acumulador+numero;
Escribir “Ingrese un numero”;
Leer numero;
contador <- contador +1;
FinMientras
Escribir “El promedio es:  “, acumulador/contador;
FinProceso

promediolista

Mostrar en pantalla todos los enteros pares comprendidos entre 1 y 100.

Proceso paresMenoresQue100
contador<-0;
Mientras contador <= 100 Hacer
Escribir contador;
contador<-contador+2;
FinMientras
FinProceso

pares

Pueden descargar el PSeInt desde su página oficial PseInt

Saludos

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s