Suspensión del escrito de mañana

Les informo que el escrito de Programación I y Lógica para Computación  de mañana viernes se suspende y queda para el martes 16 de julio después de las vacaciones.

Felices vacaciones descansen y estudien …

Saludos

Anuncios

Material Programación I

A l@s alumn@s  de de 1º BD Matutino  recuerden que el próximo viernes 28 tenemos el escrito de Programación I correspondiente a junio. Les dejo algunos de los pseudocódigos  y diagramas de flujo, trabajados en PseInt, para practiquen. Recuerden utilizar la ventana del paso a paso, con detalle explicado, para entender mejor los algoritmos implementados.

Los temas a evaluar corresponden a los conceptos de:

  • Variable
  • Contador
  • Acumulador
  • Diagrama de flujo
  • Pseudocódigo

Estructuras de control:

  • Si…entonces
  • Mientras….hacer

Algunos ejemplos trabajados:

Entrar gratis a un baile si se es dama y mayor de edad.
Proceso entrarAlBaile
Escribir ‘Ingrese edad’
Leer edad
Escribir ‘Ingrese sexo f – Femenino m – Masculino’
Leer sexo
Si edad>=18 Y sexo=f Entonces
Escribir ‘Puede entrar gratis al baile’
Sino
Escribir ‘NO puede entrar gratis al baile’
FinSi
FinProceso
baile

Determinar el mayor de dos números ingresados por teclado.

Proceso determinarElMayor
Escribir “Ingrese un numero”;
Leer numero1;
Escribir “Ingrese otro numero”;
Leer numero2;
Si numero1 > numero2 Entonces
Escribir “El mayor es: ” , numero1;
Sino
Si numero1 < numero2 Entonces
Escribir “El mayor es: ” , numero2;
Sino
Escribir “Los numeros son iguales”;
Fin Si
Fin Si
FinProceso

mayor

Hallar el promedio de una lista de números positivos terminada con -1.

Proceso promedioLista
numero<-0;
acumulador<-0;
contador<- -1;
Mientras numero <> -1 Hacer
acumulador<-acumulador+numero;
Escribir “Ingrese un numero”;
Leer numero;
contador <- contador +1;
FinMientras
Escribir “El promedio es:  “, acumulador/contador;
FinProceso

promediolista

Mostrar en pantalla todos los enteros pares comprendidos entre 1 y 100.

Proceso paresMenoresQue100
contador<-0;
Mientras contador <= 100 Hacer
Escribir contador;
contador<-contador+2;
FinMientras
FinProceso

pares

Pueden descargar el PSeInt desde su página oficial PseInt

Saludos

Bases de Datos II

Les dejo el MER que obtuvimos en la clase anterior, ahora les toca hallar el Modelo Relacional y resolver las siguientes consultas:

  1. Nombre de los laboratorios
  2. Pacientes masculinos
  3. Teléfono y  dirección del  Hospital de Maldonado
  4. Nombre de los Médicos Pediatras
  5. Médicos por Hospital
  6. Cantidad de pacientes femeninos internados en el Hospital de San Carlos
  7. Salas por Hospital que tengan más de 10 camas
  8. Sala/s donde se encuentra internado Juan Pérez
  9. Trabajos realizados por los laboratorios ordenados por fecha
  10. Nombre de los médicos que atendieron el día 25/5/13
  11. Nombre de los pacientes de diagnóstico reservado

continuará….

Agradecemos al alumno Matías Lampes por la elaboración del diagrama.

MER HOSPITAL

MER HOSPITAL

Saludos

Prácticos de Introducción a la Computación de la Profa. Rosario Corbo

Para l@s alumn@s de 1º  BD Informática Matutino  les dejo los últimos prácticos de Introducción a la Computación de la Profesora Rosario Corbo:

Saludos

Lenguajes de Programación

 

Les dejo dos enlaces interesantes sobre lenguajes de programación:

  • En www.levenez.com  completo árbol genealógico de los diversos lenguajes de programación. Pueden descrgarlo en pdf, si lo prefieren,  son unas cuantas páginas…

Saludos

babel

Defensa Final de 3º EMT Informática

La defensa final del proyecto de 3º EMT Informática se hará el mismo día de la entrega el próximo lunes 10 de diciembre a las 16 horas.  Esto es a excepción de aquellos alumnos que ya habían coordinado con el Prof. Eduardo Olivera  la entrega en la mañana,  por razones de trabajo, donde la misma será a las 10hs.

Saludos.

El profe.

ANEP – GUIA PARA ELEGIR QUE ESTUDIAR

 El Programa de Orientación Vocacional Ocupacional de la Administración Nacional de Educación Pública, presenta una nueva edición de la Guía de Opciones Educativas “¿Qué puedo elegir?”, con la idea de facilitar el acceso a la información actualizada del abanico de carreras, cursos y/o formación en diferentes áreas, con distribución en todos los centros educativos públicos del país.

Descargar AQUÍ

 

Simulacro de escrito Introducción a la Computación y Lógica

Les dejo un simulacro de escrito de Introducción a la Computación y Lógica para Computación para que practiquen. Hagan todo lo que puedan así la próxima clase la dedicamos a aclarar dudas para el último escrito del año.

Simulacro de Escrito Inco y Logica

Saludos

Proyecto final 2º EMT Informática 2012

Les dejo la letra del Proyecto final para 2º EMT Informática Matutino y las pautas para la documentación.

proyecto2_2012

DocumentacionProyecto2012

También les dejo la clase de hoy con los comandos básicos SQL  trabajados… por supuesto que los errores fueron editados 😉

clase 25 9 12

Saludos

 

Tarea 1° Informática Nocturno

Para Sistemas Operativos crear un ayuda memoria con los comandos  trabajados en DOS sobre el manejo de directorios, archivos  y comodines.   Este debe entregarse en hojas escritas a mano el próximo martes.

Para Introducción a la Computación entregar vía correo electrónico a profejcutu@gmail.com con asunto 1BF los ejercicios 1 y 2 del práctico 3 AQUÍ.

Además también deben resolver y enviar el siguiente ejercicio:

Dada la siguiente Matriz Booleana  asociada a la relación R definida en A={1,2,34}.

a) Determinar R por extensión y representarla mediante un digrafo.

b) Indica que propiedades  cumple  R justificando.

saludos

PD:  Recuerden fecha límite para la entrega viernes 31 de agosto hora 23:59.